SofType™ 4.5
International On-screen Keyboard
For Windows 95/98/ME/NT/2000/XP
User Manual
SofType

SofType™, Dragger™ and AutoClick™ are trademarks of Origin Instruments Corporation. HeadMouse® is a registered trademark of Origin Instruments Corporation.

SofType 4.5 User Manual Published by:

Origin Instruments Corp.
854 Greenview Drive
Grand Prairie, TX 75050
Tel: 972-606-8740
Fax: 972-606-8741
email: info@orin.com
web: www.orin.com

© 2000 Origin Instruments Corp. All rights reserved.

No part of this publication may be reproduced or transmitted in whole or in part by any means without the written permission from the publisher.
# Table of Contents

**Introduction** ........................................................................................................... 2  
  Product Support ........................................................................................................ 2  
  Software Registration ............................................................................................... 2  
  Upgrading Note ......................................................................................................... 2  
  What’s New in SofType 4.5 ...................................................................................... 2  

**Installation** ............................................................................................................. 4  

**Overview** .................................................................................................................. 5  

**Chapter 1  The Keyboard** ....................................................................................... 7  
  Appearance .................................................................................................................. 7  
  Keyboard Layouts ....................................................................................................... 12  
  Custom Keyboard Layouts .......................................................................................... 16  
  Moving & Sizing the Keyboard ................................................................................... 18  
  Key Size ..................................................................................................................... 20  
  Colors and Fonts ....................................................................................................... 20  

**Chapter 2  Dragger & AutoClick** ........................................................................... 23  
  The Dragger Toolbar .................................................................................................... 23  
  Placement & Orientation: ........................................................................................... 23  
  Resizing the Buttons ................................................................................................... 25  
  AutoClick ................................................................................................................... 25  
  Clicking Functions ...................................................................................................... 26  
  Jitter Box .................................................................................................................... 26  
  Delay Time .................................................................................................................. 27  
  AutoClick Sound ........................................................................................................ 27  
  Other Dragger Settings ............................................................................................... 27  
  Repeat Click .............................................................................................................. 27  

**Chapter 3  Text Entry & Word Prediction** ............................................................... 29  
  Text Entry .................................................................................................................. 29  
  Word Prediction ......................................................................................................... 29  
  Add Words to the Word List ...................................................................................... 30  
  Load Dictionary .......................................................................................................... 32  
  Edit Words Menu ........................................................................................................ 32  
  Edit and Delete Words in a Word List ....................................................................... 33  
  Word Statistics .......................................................................................................... 33  

**Chapter 4  Abbreviation Expansion & Macros** ...................................................... 35  
  Using Abbreviation Expansion .................................................................................. 35  
  Defining/Editing Abbreviations ................................................................................ 35  
  Using Macros ............................................................................................................. 36  
  Macro Commands ...................................................................................................... 36  
  Defining/Editing Macros ............................................................................................ 36  
  Macro Tips ................................................................................................................. 37  
  Example Macros ........................................................................................................ 37  

**Index** ......................................................................................................................... 39
Introduction

Congratulations on your purchase of SofType from Origin Instruments Corporation. This manual is a guide to the use and operation of SofType 4.5 International On-screen Keyboard. While SofType does not require extensive training, it is advisable to review this manual before using, to familiarize yourself with this product.

SofType is one of the finest on-screen keyboards available, offering an exceptional alternative to the standard keyboard. Origin Instruments Corporation is committed to providing quality products and exceptional service.

Product Support

Origin Instruments will provide technical support via telephone or email. If the supported product proves defective within 1 year from the date of shipment, Origin Instruments, at its option, will provide a fix for the defective product, will provide a replacement, or will refund the purchase price of the defective product. To obtain service under this support program, the customer must notify Origin Instruments Corp. of the defect before the expiration of the support period.

Contact Information: Origin Instruments Corporation
854 Greenview Dr
Grand Prairie, TX 75050
Tel: 972-606-8740
Fax: 972-606-8741
email: support@orin.com
Web: www.orin.com

Software Registration

Please complete and return your SofType registration form. Registering your software ensures that you are informed of software updates and new product announcements.

Upgrading Note

Individuals upgrading from a previous version of SofType should be aware that their current SofType settings will not be preserved.

What’s New in SofType 4.5

Supports International Keyboards: SofType 4.5 is designed to display Roman character language keyboards. When a language is selected from within Windows Settings, the keyboard will automatically display the appropriate keyboard for the language selected.

Import Words: Words can easily be imported into a new or existing word list dictionary from any text document. Multilingual users can create separate word lists for different languages. SofType stores the word lists as files, which can then be accessed when needed.

New Dragger Size: In addition to the three sizes already available, the Dragger toolbar is now also available in a new miniature size.
**Start Up Options:** This feature allows the user to set SofType to start automatically when Windows starts and can be used to logon. Start-up commands, such as determining the keyboard layout that SofType displays when started, can be specified as well.

**Automatically Add Words:** This feature allows the user to automatically add new words to the word list dictionary.

**Arrange COMMON Word List:** SofType no longer automatically sorts the COMMON word list. The user may now define the order the words are arranged in this list.

**Macro Capability:** Selecting the Use Macros command from the Keyboard menu enables macro capability. Macros are phrases, commands and other commonly used strings of text that SofType will type for you. Macros can eliminate many keystrokes.

**Abbreviation Expansion:** Selecting the Use Abbreviations command from the Keyboard menu enables the abbreviation expansion feature. Abbreviations are predefined by the user and allow you to quickly type frequently used word and phrases with a minimum of three clicks.
Installation

When the installation process is complete, SofType 4.5 will be added to Window’s Programs menu.

**Diskette:**
1. Start Microsoft Windows.
2. Insert the SofType 4.5 diskette into your 3.5” floppy drive.
3. Click the Windows “Start” button and select Run…
4. Enter a:setup in the command line text box (or b:setup if your 3.5” floppy disk is in the b: drive).
5. Click OK to begin the installation process.
6. Follow the instructions given by the install program.

**CD-Rom:** If the installation process does not automatically begin, follow the instructions below.
1. Start Microsoft Windows.
2. Insert the CD-Rom into your CD-Rom drive.
3. Click the Windows “Start” button and select Run…
4. Enter the drive that corresponds to your CD-Rom. For example: m:setup
5. Click OK to begin the installation process.
6. Follow the instructions given by the install program.

**Automatically Start SofType:** If you want SofType to start automatically, follow the instructions below.
1. Select SofType’s File menu.
2. Select Startup Options… (This will open the Startup Options dialog box.)
3. Select Start SofType automatically.
4. Click OK.

*Note: This feature is discussed in more detail in chapter 1.*
SofType is a software utility which replaces the functionality of a standard keyboard with a full featured on-screen keyboard. SofType can be accessed using a mouse or mouse emulator such as the HeadMouse®. SofType 4.5 is compatible with Windows 95/98/ME/NT/2000/XP. SofType works by generating an image of a keyboard on the computer screen. The keyboard image displayed will correspond to the language selected from within Windows settings. When a key is selected, the character represented by that key is sent to the active Windows application.

SofType has a built-in dwell selection feature called AutoClick™. When AutoClick is enabled, clicking functions are performed by holding the pointer motionless for a programmable length of time.

Dragger is a toolbar integrated into SofType which allows AutoClick and single-switch users to perform all of the common clicking functions of a two-button mouse. Specific buttons on the Dragger toolbar are associated with the common clicking functions. Dragger also has an On/Off button, which enables and disables AutoClick’s dwell feature.

Floating the Dragger toolbar will allow the user to position Dragger on a seldom-used area of the screen. SofType’s keyboard can be hidden and still allow the use of Dragger’s dwell feature. This is especially useful while using applications that do not require text entry, such as a web browser or card game like Solitaire.

Word Prediction eliminates keystrokes when words are selected from the word list. As you begin to type, a list of words is displayed in the Word Bar, which match the spelling of the word you type. When your word appears in the list, simply select that word. This feature will automatically complete the word and add a space at the end.

Importing words from any text document is a feature of SofType that provides a quick and easy means of adding words to an existing word list or creating a new word list. This feature allows the user to keep word lists that correspond to the language in use.

The Blackhand Menu is a fast convenient means of accessing SofType’s menus and other features. When the hand-shaped mouse pointer passes over the keyboard background, it will turn from white to black, thus the name Blackhand. Performing a left click where the hand is black will open a shortcut menu to these features.

SofType offers a variety of keyboard layouts ranging from a very basic keyboard such as the Minimal layouts to a more comprehensive keyboard such as the QWERTY layout. It is also possible to create your own keyboard layout by using a text editor to edit an existing layout.

Macro capability and abbreviation expansion have been added to SofType’s already extensive list of features. These two new features will make using SofType even easier and more enjoyable by eliminating keystrokes when entering frequently used phrases, commands and other text entries.
Chapter 1 The Keyboard

Appearance
SofType offers twelve different keyboard layouts. Most of these layouts have the same basic appearance of a standard keyboard. The Default Keyboard shown in figure 1 consists of seven different areas.

Title Bar: This displays the name of the program, program icon and the name of the keyboard layout that is currently displayed. A Close and Minimize icon are also available from this bar. When the Close SofType icon is selected, a window opens containing the message “Do you really want to quit SofType?” The user will have the option of selecting “Yes” or “No.” This is to prevent closing SofType due to inadvertent clicks.

Menu Bar: SofType’s Menu Bar contains six menus to select from to access all of its features and options. These menus are also accessible from the Blackhand Menu discussed later in this chapter.

File: From this menu the user can select different keyboard layouts or word list dictionaries, save or edit words in a word list dictionary, create a new word list dictionary and reset the frequency of use statistics. [See figure 2]
**SofType Chapter 1**

**Startup Options**… available from SofType’s File menu provides the option of starting SofType automatically when the Windows is started. After opening the Startup Options dialog box, select Start SofType automatically from the Global settings. If a password is required at startup, select the “I need SofType to logon to Windows.” check box. When the computer is started, a basic keyboard will appear at logon for the purpose of entering a password. A “Command line options” edit field is available for setting the criteria, which determines how SofType starts. These commands are listed below. Only a user with Administrator privileges may change the Global settings under Windows NT/2000/XP. The Per-User settings allow multiple users of the same computer to personalize startup options.

**Command Line Options**: There are two ways to specify command line options; the first, described above, is by using the Startup Options dialog box. Another method is to edit a shortcut. To do this locate and right click a shortcut to SofType, select Properties, click the Shortcut tab, then modify the end of the Target field. Be sure there is a space between each option, and between the file specifications pointing to SofType. Command line options are not case sensitive; NOMENU and nomenu are equivalent.

Example: "C:\Program Files\Origin\SofType 4.5\SofType.exe" NOSPLASH "Vertical.kys".

**Command Lines**:

"layout.kys"**: Forces the keyboard layout specified to be displayed when SofType starts. When "Default.kys" is specified on the command line the Default layout is loaded. The layout name must be in quotation marks.

**NOSPLASH**: Prevents the splash-screen graphic from being displayed when SofType starts.

**SIZING**: Causes the active application to resize when SofType is minimized or hidden and restored or unhidden.

**NOBHAND**: The Blackhand menu will not be displayed when the keyboard background is clicked. When this option is specified the Blackhand menu cannot be turned on from within SofType. The command must be removed and SofType must be restarted to display the Blackhand menu again.

**NOCAPTION**: Displays the floating Dragger toolbar without a title bar.

**CLEANREG**: This option is used to clear or reset all of SofType’s settings. SofType will start invisibly; remove all of its settings from the Windows registry then exit.

**Exit**: To close SofType select Exit from the File menu or click on the x in the upper right corner of the SofType window. A dialog box will open asking, “Do you really want to quit SofType?” Selecting Exit & Launch Dragger32 will close SofType and open Dragger32 if this program is also installed on the computer in use.

**Run**: This menu allows applications to be launched from within SofType. Select Edit Run… from the Run menu. This will open the Edit Run Menu dialog box. To add a program to the Run list, click on the Add button. This will open a browse window from which to select a program. After the desired selections have been made, click
Open then click OK. The program will now appear in the Run Menu Contents. Up to ten programs can be added to the Run Menu. The programs added will now appear in the Run menu. [See figure 3]. To remove a program, simply select it from the Edit Run Menu dialog box and click on the Delete button.

**Keyboard**: From this menu [See figure 4] adjustments can be made to the keyboard appearance in relation to size, colors and fonts and to the key shape and highlighting preference. This is discussed in more detail later in this chapter. The Double-click CAPs and Show Case features are reviewed in chapter 3. The Abbreviation Expansion and Macro features are also accessible from this menu and are discussed in Chapter 4.

**Mouse**: Selecting Big Cursor from the Mouse menu will increase the size of the pointer while it is positioned over SofType’s keyboard. [See figure 5] AutoClick, Repeat Click and Dragger are discussed in chapter 2.

**View**: This menu provides access to the Word Bar Settings dialog box discussed in chapter 3. The Title and Menu Bars can be hidden to create more screen space. This can be done by selecting Title & Menu Bar... from the View menu. [See figure 6] The Blackhand Menu can be used to unhide the Title & Menu Bar. Features, which
provide ease in placement of SofType's keyboard, are accessible from the View menu also.

**Help:** The Help menu is located on the right side of the Menu Bar. [See figure 7]

![Help Menu](image)

**Word Bar:** This is a COMMON word list for Word Prediction users. If Word Prediction is not being used, the Word Bar can be hidden to create more screen space by selecting Word Bar… from the View menu to open the Word Bar Settings dialog box. Unselect the Words On check box and click OK. Another method is to select Word Bar from the Blackhand Menu.

**Dragger Dock Area:** This is the area that the Dragger toolbar can be docked in. Four areas are actually available. They are located above, below, to the right or to the left of the Key Area. This area collapses when Dragger is floating.

**Key Area:** This area contains all of the keyboard keys available for the chosen layout including directional and command keys.

**Status Bar:** This bar displays the text entry status and mouse coordinates and also contains Num Lock and Scroll Lock status. The Status Bar can be positioned above or below the Key Area, or it can be hidden. To reposition or hide this bar, select Status Bar… from the View menu. This will open the Status Bar Settings dialog box. [See figure 8] After selections have been made click OK.

![Status Bar Settings](image)

**Background:** Clicking on the background within the Key Area will reveal the Blackhand Menu. [See figure 9a] The Blackhand menu is an alternative means of accessing SofType’s menus and other features. When the hand-shaped mouse pointer passes over
the Key Area background, it will turn from white to black, thus the name Blackhand. [See figure 9b]

Other features accessible from the Blackhand menu are reviewed below. Some of these menus are also accessible from SofType's Menu Bar and have been reviewed earlier in this chapter.

**File:** Accessible from SofType’s Menu Bar and Blackhand menu.

**Run:** Accessible from SofType’s Menu Bar and Blackhand menu.

**Keyboard:** Accessible from SofType’s Menu Bar and Blackhand menu.

**Mouse:** Accessible from SofType’s Menu Bar and Blackhand menu.

**View:** Accessible from SofType’s Menu Bar and Blackhand menu.

**Help:** Accessible from SofType’s Menu Bar and Blackhand menu.

**Save Word:** Accessible from the Blackhand menu. In the Blackhand menu this option will appear only when you have typed a word that is not already in the word list dictionary. The word that will be added to the dictionary is displayed in parentheses next to this option. [See figure 9a]

**Dismiss Menu:** Accessible from the Blackhand menu. Closes the Blackhand menu.

**Word Bar:** Accessible from the Blackhand menu. Selecting this will hide or show the Word Bar.

**Resize Active App:** Accessible from the Blackhand menu. This feature adjusts the size and location of the active application to fill the screen space remaining above or below SofType’s keyboard. This will allow the user to enter text into an application without
the flow of text disappearing behind the keyboard. To restore the application to a full screen size, simply click on the Maximize button located in the top right corner of the application.

**Minimize:** Accessible from the Blackhand menu. Minimizes the SofType window. It is important to note that minimizing SofType is not the same as hiding the keyboard. Hiding the keyboard is discussed later in this chapter.

**Switch To…:** Accessible from the Blackhand menu. Opens a Task list, which allows you to quickly move between open applications.

**Reboot:** Accessible from the Blackhand menu. Will allow you to restart Windows, reboot system, or log off then log on as different user. Choose Reboot to select from three ways to restart your computer: Reboot System closes all running programs and restarts your computer. Restart Windows closes all running programs and restarts Windows. (This option is disabled in Windows NT.) Log Off Windows closes all running programs, logs the current user off of Windows, and then allows you to log onto Windows as a different user.

*Note: When you select one of the Reboot options, SofType attempts to close all running programs. If the attempt fails to close any program SofType will not close.*

**Keyboard Layouts**

As mentioned earlier in this chapter, SofType offers a choice of twelve different keyboard layouts; in addition, it is possible to edit an existing layout using a text editor. To choose a keyboard layout, select **Load Layout…** from the **File** menu. Select the desired keyboard layout and click **Open**.

The chart on the next page shows the keyboard layout file name, number of key rows in the layout and the general placement of keys. A blank cell indicates that key or set of keys is not available within that layout. This chart is useful in identifying differences between similar layouts and locating keyboards with specific features such as function keys.

Figures of seven of these layouts follow the chart for visual perspective. Variations of the same keyboard are not shown. [See figures 10a – 10f]
**Alphabetic** layouts have the letter keys arranged in alphabetical order.  
**Chubon** layout arranges the keys by frequency of use with the most frequently used keys clustered toward the center.  
**QWERTY** layouts refer to a standard keyboard layout.  
**Vertical** layout is arranged with the letter keys in a vertical arrangement.  
**Minimal** layouts contain only the basic keys.

Key code:

<table>
<thead>
<tr>
<th>L: Left</th>
<th>R: Right</th>
<th>U: Upper</th>
</tr>
</thead>
<tbody>
<tr>
<td>UL: Upper Left</td>
<td>UR: Upper Right</td>
<td>UC: Upper Center</td>
</tr>
<tr>
<td>LL: Lower Left</td>
<td>LR: Lower Right</td>
<td>LC: Lower Center</td>
</tr>
<tr>
<td>CL: Center Left</td>
<td>CR: Center Right</td>
<td>C: Center</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Keyboard File Name</strong></th>
<th><strong>Alpha Key Layot</strong></th>
<th><strong>F Keys</strong></th>
<th><strong>Esc</strong></th>
<th><strong>NL</strong></th>
<th><strong>SL</strong></th>
<th><strong>Print Screen</strong></th>
<th><strong>Arrow Keys</strong></th>
<th><strong>Home Keys</strong></th>
<th><strong>Num Pad</strong></th>
<th><strong>Macro</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>AlphaKey.kys (6 rows)</td>
<td>Alphabetic (3 rows)</td>
<td>R</td>
<td>UL</td>
<td>UC</td>
<td>UC</td>
<td>UC</td>
<td>LC</td>
<td>UR</td>
<td>R</td>
<td>UC</td>
</tr>
<tr>
<td>Alternate One.kys (6 rows)</td>
<td>Alphabetic (2 rows)</td>
<td>R</td>
<td>CR</td>
<td>UR</td>
<td>CR</td>
<td>LR</td>
<td>LL</td>
<td>LC</td>
<td>C</td>
<td></td>
</tr>
<tr>
<td>Alternate Two.kys (6 rows)</td>
<td>Alphabetic (4 rows)</td>
<td>R</td>
<td>UC</td>
<td>LR</td>
<td>LR</td>
<td>CR</td>
<td>UC</td>
<td>UR</td>
<td>C</td>
<td></td>
</tr>
<tr>
<td>Chubon.kys (6 rows)</td>
<td>Chubon (frequency of use)</td>
<td>UL</td>
<td>CR</td>
<td>UR</td>
<td>UR</td>
<td>LR</td>
<td>R</td>
<td>C</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Default.kys (6 rows)</td>
<td>QWERTY (6 rows)</td>
<td>U</td>
<td>UL</td>
<td>CR</td>
<td>CR</td>
<td>UR</td>
<td>LR</td>
<td>R</td>
<td>LR</td>
<td></td>
</tr>
<tr>
<td>Minimal.kys (3 rows)</td>
<td>Alphabetic (2 rows)</td>
<td>R</td>
<td>UL</td>
<td>CR</td>
<td>CR</td>
<td>LR</td>
<td>U</td>
<td>C</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Minimal2.kys (4 rows)</td>
<td>Alphabetic (2 rows)</td>
<td>LL</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Minimal3.kys (4 rows)</td>
<td>Alphabetic (2 rows)</td>
<td>LL</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Minimal4.kys (4 rows)</td>
<td>Alphabetic (2 rows)</td>
<td>UL</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>NumPad.kys None</td>
<td>LL</td>
<td>LC</td>
<td>U</td>
<td>C</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>QWERTY.kys (6 rows)</td>
<td>QWERTY (6 rows)</td>
<td>U</td>
<td>UL</td>
<td>CR</td>
<td>UR</td>
<td>CR</td>
<td>LR</td>
<td>UR</td>
<td>R</td>
<td>CR</td>
</tr>
<tr>
<td>Vertical.kys</td>
<td>Vertical</td>
<td>UL</td>
<td></td>
<td>UL</td>
<td>U</td>
<td>LR</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Home Keys refer to the following keys: Home, End, Insert, Delete, Page Up, Page Down*
Figure 10a: AlphaKey Keyboard

Figure 10b: Alternate One Keyboard

Figure 10c: Chubon Keyboard
Figure 10d: QWERTY Keyboard

Figure 10f: NumPad Keyboard

Figure 10e: Vertical Keyboard
Custom Keyboard Layouts

CAUTION: If you cannot use your computer without SofType you may need someone who can use the computer's keyboard if you get in trouble.

The easiest way to create your own SofType keyboard is to edit an existing SofType keyboard. Follow these steps to edit an existing keyboard file:

1. Using the Options menu item KEYBOARD LAYOUT, determine which existing layout you want to edit.
2. Using Microsoft Window's Explorer, Make a backup of the .KYS file you wish to edit.
3. Load Microsoft Windows "Notepad" application, or other text editor.
4. Load the .KYS file you wish to edit into Notepad.

What you see with Notepad:

Comments: Lines beginning with a semicolon (;) are comment lines. A comment can contain anything you wish.

Note: A comment line must have a ; as the very first character of the line.

Key Line: A key line looks like this:
1,27,27,0,6,"ESC"

Key lines contain information that SofType uses to represent a key to you and to other application. Key Lines contain 6 fields as follows:

- Scan Code-----------------------------------------------1,
- Virtual Key Code-------------------------------------27,
- ASCII Code--------------------------------------------27,
- Extended Code-----------------------------------------0,
- Color Code----------------------------------------------6,
- Text that appears on the key face----------------"ESC"

Unless you understand exactly what fields 1-5 are, DO NOT change them.

You may change the text of the key (field 6) if you desire. Any text for a key must appear between two quotes. Text for a quote (") would be "".

Please note that the direction keys in the .KYS file do not appear as arrows. They appear as follows: CURLEFT, CURRIGHT, CURUP, CURDOWN.

SPACE: SPACE is a command to SofType to add a space or gap between keys. The gap associated with SofType's SPACE command is one pixel. You may use more than one consecutive SPACE command. SPACE only adds a gap in the horizontal direction. There is no command for a vertical gap.

NEWLINE: NEWLINE is a command for SofType to begin a new line (i.e., row) of keys. A new line of keys begins at the left edge of SofType's window or the left edge of the current "block".

NEWBLOCK: NEWBLOCK is a command for SofType to create a new block (i.e., section) of keys. After a NEWBLOCK command is encountered, SofType will align the new key block to the right of the previous block's widest line of keys, so that the top line
of the new block aligns with the top line of the previous block. Please refer to the following symbolic representation of a .KYS file and the resulting "layout".

**MACROKEY**: MACROKEY is used for placing SofType’s macro key within a keyboard layout. Only one MACROKEY command should appear in a layout.

```plaintext
; First block of keys
= = = =
NEWLINE = = =
NEWLINE
NEWBLOCK ; Second block of keys
= = =
NEWLINE = = =
NEWLINE = = =
NEWLINE
(= Shorthand for a key line)
```

**Symbolic representation of the resulting keyboard layout. Where "=" represents one key line.**

---

**Editing**

Select a key line and Cut & Paste to move a key, or Copy & paste to copy a key. Be sure you select all the data on a key line, or range of key lines, before you cut or copy and paste.

Add SPACEs, NEWLINEs and NEWBLOCKs as needed.

You may comment out a key line to "hide" a key from SofType.

After the .KYS file has been changed save it and load the file into SofType to see the effects. Several iterations may be required to get the desired result.
**Keyboard Settings:** These values are stored by SofType in a layout file and are associated with some of the adjustments made using the SofType menus. They should NOT be modified during the editing session. The parameters controlled by the settings are associated with key colors, key font, key size and spaces between adjacent keys.

```plaintext
[KeyboardSettings]
FontData=-16,0,0,0,700,0,0,0,0,3,2,1,34,Arial
Punctuation=191,0,0
Letters=0,0,191
Numbers=255,0,0
FKeys=255,0,0
Movement=0,0,255
Enter=255,255,0
Controls=0,0,0
Background=192,192,192
KeyFaces=192,192,192
KeySizeX/Y=8,5
KeySpaceX/Y=1,1
DeadChars=0,0,191
```

**Tip:** Before editing a .KYS file, load it into SofType and change the size and font of the keys to your preferences and needs. Changing these after you design a layout may change the alignment on certain keys in your layout.

**Moving & Sizing the Keyboard**

SofType’s keyboard can be relocated and resized by a variety of methods to best suit the needs of the user. Begin by making sure that Always on Top has been selected from the View menu to prevent the keyboard from disappearing behind the application being used. It is possible to hide the keyboard while working in applications that don’t require text entry or searching the Internet. To do so, click on the hide/show button located on the Dragger toolbar.

**Location:** It is possible to drag the keyboard by clicking and holding on SofType’s Title Bar while moving the mouse pointer. An outline of the keyboard will be visible to assist in optimal placement. (For some users, the window will visibly move as you drag.)

To quickly move the keyboard to the top or bottom of the computer screen, click on the Move SofType button on the Dragger toolbar. This feature is especially useful when the text being entered becomes hidden by SofType.

Another method of sending the keyboard directly to the top or bottom of the computer screen is to select Move Down (Up) from the View menu. To keep the keyboard at either the top or bottom of the screen, select Keep Top/Botom from the View menu this will allow the keyboard to be positioned only in these two locations.
To prevent the keyboard from moving beyond the edges of the computer screen where it would only be partially visible, select Keep on Desktop from the View menu. [See figure 11]

Size: The most convenient way to adjust the size of the keyboard is to position the mouse pointer over a corner or an edge of the SofType window, when the pointer changes to a 2-directional arrow, click and hold to drag the keyboard to the desired size.

To quickly scale down the size of the keyboard, SofType allows specific areas of the layout to be hidden. Hiding the Title, Menu, Status and Word Bars, and floating Dragger will leave only the Key Area using screen space. The user has the option to hide some or all of these areas as needed. When the Title Bar is hidden, SofType can be moved by holding the pointer over the center of any edge of the keyboard and dragging to the desired location. When the appearance of the pointer changes to a 4-directional arrow, drag the keyboard to the desired location.

Hide Title & Menu Bar: There are two ways to hide the Title & Menu Bars. One way is to click on the Shrink/Grow button on the Dragger toolbar. Access to all of SofType’s menus will still be available via the Blackhand Menu. To show these bars again simply click on the Shrink/Grow button again. Another way is to select Title & Menu Bar… from the View menu. This will open a Title & Menu Toggle window. In this window an option is available to keep SofType in this state for this session only or every time you run SofType. After making selections, click OK.

Hide Status Bar: Select Status Bar… from the View menu. This will open the Status Bar Setting dialog box. Unselect the Status Bar On check box and click OK.

Hide Word Bar: Select Word Bar… from the View menu. This will open the Word Bar Settings dialog box. Unselect the Words On check box and click OK. This option is also available from the Blackhand Menu. It is important to note that hiding the Word Bar will make Word Prediction inaccessible. Another option is to locate the Word Bar above or below the Key Area. To do this, open the Word Bar Settings dialog box. Select the desired Location toggle, Top, Bottom, Left or Right. Click OK after selections have been made.
**Key Size**

SofType has a control that allows the user to adjust the size of the keys and the gap between the keys. Utilizing this feature will not only affect the size of the keyboard, but is also an excellent stability compensation tool. Increasing the size of the keys and key gap makes it easier to hold the pointer on the desired key when instability is present. To adjust the key and gap size, select **Key Sizer**… from the **Keyboard** menu. This will open the Key Size & Gap Adjust dialog box. [See figure 12] The horizontal and vertical key size and key gap values are adjusted by changing the x and y-axis values respectively. Click OK after making the desired adjustments.

*Note: This will not affect the font size on the key face.*

---

**Colors and Fonts**

SofType provides a means of changing the colors and fonts that are displayed on the keyboard and key face. The Key Area, including the Background and Word Bar, are divided into groups; punctuation, letters, numbers, controls, etc. The colors for each of these groups can be changed to provide better contrast or make particular groups more easily identifiable. The font size, type and style on the key face, in the Word Bar and in the Status Bar can also be changed. If font size is changed, key size will change to accommodate the new character size.

**Changing Colors:** To adjust the colors select **Colors**… from the **Keyboard** menu. This will open the Color Selection dialog box. [See figure 13] On the left of the dialog box will be a listing of the Color Groups. Select the radio button associated with the color group to be adjusted. Use the **Red**, **Green** and **Blue** slider bars to adjust the color. The color for the chosen group is displayed on SofType’s keyboard as the adjustment is being made. Click OK after the desired color is achieved.

**Changing Fonts:** To adjust the font displayed on the key face, select **Fonts**… from the **Keyboard** menu. This will open the Font dialog box. From this dialog box, select the font type, style and size. A sample text will appear in the Sample area of the dialog box. Click OK after selections have been made. [See figure 14]
Figure 13: Color Selection dialog box.

Figure 14: Font dialog box.
Chapter 2  Dragger & AutoClick

The Dragger Toolbar
Dragger is a toolbar integrated into SofType, which allows AutoClick & single-switch users access to all of the common functions of a two-button mouse. Dragger converts a single click into a double click, right click or drag operation.

Dragger consists of ten buttons. [See figure 15] Four of these buttons are associated with clicking functions, one will reconfigure Dragger, one is an ON/OFF toggle for AutoClick users and the remaining four buttons are associated with SofType’s keyboard. The use of these buttons will be reviewed in this and later chapters.

Placement & Orientation:
Dragger can be docked within SofType’s keyboard either above or below or to the right or left of the keyboard. When SofType is first opened, the Dragger toolbar will be docked just above the first row of keys on the keyboard. If the Dragger toolbar is not visible, click on SofType’s Mouse menu and select Dragger… Select Dragger On and click OK. Dragger should now be visible. To relocate Dragger, simply drag the toolbar to the desired location. Dragging the toolbar is done by clicking and holding on Dragger’s background. The outline will be visible while dragging the toolbar. Upon reaching one of the docking areas, the outline will become visibly smaller to indicate where to drop the toolbar. [See figure 16]
Dragger can also “float”, which means it can be removed from within the keyboard and positioned anywhere on the screen. This feature provides more ease of use as it allows the user to decide the most optimal placement for his/her comfort. For instance, when playing Solitaire, positioning Dragger just below the card stack may be most comfortable; however, if while searching the Internet or typing a letter, the user may prefer to move Dragger to the edge of the screen out of the way of your work. It is possible to float Dragger in one of the following ways: Drag it off of the keyboard to the preferred position, double click on Dragger’s background or use the Orientation button as described below. Once Dragger is floating, a title bar appears which can be used to drag the toolbar for more ease in repositioning.

Dragger can be configured either vertically or horizontally, in either a single or a double line. To change the orientation, click on the Dragger Orientation Button [See figure 17] until you reach the desired configuration. Clicking on this button while Dragger is docked in the keyboard will also cause it to float.
Resizing the Buttons
Dragger’s buttons can be resized to best suit the needs of the user. To resize the buttons, click on the Mouse menu and select Dragger... The Dragger Settings dialog box will open. [See figure 18] From here the user may select from Normal, Large, Larger or Miniature button sizes. Click OK after selections have been made.

AutoClick
AutoClick is a dwell selection technique integrated into SofType. When AutoClick is enabled, clicking functions can be performed by dwelling, or holding the pointer motionless, for a programmable length of time. When the delay time has expired, a click will occur. To enable AutoClick, click on SofType’s Mouse menu and select AutoClick... The AutoClick Settings dialog box will open. [See figure 19b] Select the AutoClick On check box and click OK. This will enable AutoClick. The AutoClick On/Off Button on Dragger’s toolbar can then be used to activate the dwell feature. [See figure 19a] This button will not be available unless AutoClick is enabled in the AutoClick Settings dialog box. To use AutoClick, simply dwell on this On/Off button; the button will have the physical appearance of being depressed and highlighted. To temporarily turn off AutoClick, dwell on the On/Off button again. This is important to avoid sporadic clicking. This button always remains dwell-sensitive allowing the user to work more independently with less outside assistance.
Clicking Functions

When AutoClick is activated, a single left click will occur whenever the pointer is motionless. To perform other clicking functions, drag, double click or right click, the appropriate button on the Dragger toolbar must be used. [See figure 20] First dwell on the appropriate button; the next place the pointer dwells will perform that function. For instance, to perform a drag first dwell on the Left or Right Drag Button; the next place the pointer dwells would begin the drag, and the next place the pointer dwells will end the drag. Double clicks and right clicks are performed in the same manner. AutoClick will automatically revert back to a single left click after the function is performed.

Dragger’s Clicking Function Buttons can also be locked to allow repeated use of that particular function. To lock one of these buttons, dwell on the button a second time. The physical appearance of the button will change to show that it is locked. [See figure 21] When a button is locked, AutoClick will perform that button’s function instead of a left click whenever the pointer is motionless. To unlock the button simply dwell on it a third time.

If the buttons will not lock, you may need to select the Allow Buttons to Lock option from the Dragger Settings dialog box. To open the Dragger Settings dialog box, click on the Mouse menu and select Dragger… After making the desired selections, click OK.

Jitter Box

The Jitter Box is a stability compensation feature useful for people who use AutoClick but have difficulty holding the pointer motionless for the length of time necessary to perform a click. It is, in actuality, an invisible box that can be adjusted in size. This box determines the size of the area that the pointer needs to be in to be considered motionless. By increasing the size of the Jitter Box, a person who is unable to hold the pointer motionless but can keep the pointer within the Jitter Box area, can then cause AutoClick to perform a click as though the pointer was motionless.

To adjust the size of the Jitter Box, click on SofType’s Mouse menu and select AutoClick… The AutoClick Settings dialog box will open. Use the Jitter Box Size slider bar or click on the arrows to make the desired adjustment. The Jitter Box Preview shows
the size of the Jitter Box as it is being adjusted. [See figure 18b] After making the adjustment, click OK.

**Delay Time**
The delay time refers to the length of time the pointer must remain motionless before a click will occur. This length of time can be programmed from .2 to 10 seconds. To adjust the delay time click on SofType’s Mouse menu and select AutoClick... The AutoClick Settings dialog box will open. Move the AutoClick Delay slider bar or click on the arrows to make the adjustment then click OK.

**AutoClick Sound**
When enabled, AutoClick provides an auditory feedback as each click occurs. By default, this is a brief “click” however, if a multimedia sound system is installed on the computer being used, this sound can be changed from the Sounds Properties dialog box in the Control Panel of the computer. It is important to note that a very brief sound must be used in order not to interfere with the AutoClick function.

To enable AutoClick Sound, click on SofType’s Mouse menu and select AutoClick... The AutoClick Settings dialog box will open. Select the Sound on AutoClick check box and either Internal Speaker or Multimedia Speakers. Click OK.

**Other Dragger Settings**
Additional options are available in the Dragger Settings dialog box accessed through the Mouse menu.

**Tooltips On:** Selecting this option will provide a description of each of Dragger’s buttons as the mouse pointer passes over it.

**Flat Buttons:** When this option is selected, Dragger buttons will appear flat and they will highlight as the mouse cursor moves over them.

*Note: This option will be grayed out if your version of Windows does not support flat buttons.*

**Show Mouse Coordinates:** Selecting this option will display the x and y positions of the mouse pointer in SofType’s status bar.

**Repeat Click**
This feature will allow repetitive clicks by holding down the key just as a standard keyboard would. Select Repeat Click… from the Mouse menu. This will open the Auto Repeat Adjustment dialog box. [See figure 22] Select the Repeat Click On check box to enable this feature. Key Down Delay determines how long you must hold down the mouse button before SofType starts repeating the key. Key Repeat determines how quickly a character will be repeated. To repeat the entry of a key character, select the drag button first, then select the key to be repeated.
Figure 22: Auto Repeat Adjustment dialog box.
Chapter 3  Text Entry & Word Prediction

**Text Entry**

To begin entering text, first select an application to type to just as if using a conventional keyboard. Place the cursor in the location where text entry is to begin. This will bring the focus to that particular application. When a key is then selected from SofType’s keyboard, the character represented by that key is sent to the active application.

Capitalizing is basically the same as on a standard keyboard. Select the Shift key before entering text, to capitalize the first letter of a word. The Shift key will remain depressed until the first letter has been entered, remaining characters will be entered in lower case. Clicking twice on the SHIFT key will cause it to remain depressed until it is clicked on a third time. Selecting the Cap key will lock caps so that every character will be entered in upper case format. To unlock, click on the Cap key a second time. To display the case format in effect, on the keyboard, upper or lower case, select Show Case from the Keyboard menu. [See figure 23] Another method of capitalization is to select Double-click CAPs from the Keyboard menu. This allows for entry of a character in upper case simply by double clicking on that character.

![Figure 23: Characters displayed in upper case when Show Case is selected from the Keyboard menu.](image)

**Word Prediction**

Word Prediction is a feature that reduces keystrokes when words are selected from the word list. As the user begins to type, a list of words is displayed in the Word Bar, which match the character sequence being entered. If the word being entered appears on the list, selecting that word with a single left click, will enter the remaining characters and a space, in preparation for the next word. SofType offers the option of displaying the words listed alphabetically or by frequency of use. To select the desired order, select Word Bar… from the View menu. This will open the Word Bar Settings dialog box. In the Completion Mode area select Alphabetic or Prediction.

The word list not only contains words for each letter of the alphabet, it also contains a list of COMMON words. This would include commonly used short words, such as the and that,
conjunctions, word endings and punctuation marks. The word endings and punctuations appear in the word list with the symbols "< -" in front of the entry and they have a special feature for removing the space at the end of a word, adding the ending/punctuation and then adding a space. For example, if the word "support_" is selected from the word list, then "< -ed" is selected; the result would be "supported_" (_ signifies a space.)

**Word Bar Settings:** [See figure 24] As discussed in chapter 1, the Words On toggle will allow you to show or hide the Word Bar. Use the radio buttons in the Location area to determine placement of the Word Bar within the keyboard. The Size area is used to set the number of columns and rows of words that appear in the Word Bar, as well as the number of characters in each word. Dynamic Words is useful for multi-lingual users. When selected, SofType will automatically load dictionary files in different languages if they are present.

![Figure 24: Word Bar Setting dialog box.](image)

**Add Words to the Word List**

Words can be saved manually into the word list, added automatically as they are typed or by entering the new words directly into the Edit Words dialog box located in the File Menu. Words can also be imported from a text document into an existing word list or to create a new word list.

**Manual Add:** If you wish to save a word manually, type the word (do not add a space or select the ENTER key) then select **Save Word** from the **File** menu. Entering a space or clicking on the ENTER key after typing a word, resets the word list and makes the **Save Word** option unavailable. After using this method to add a word to the word list, you will need to select the application you wish to enter text into before you resume typing.

*Note: It may be preferred to use the Blackhand Menu to save a word, as this method will not transfer focus from your application to SofType.*

**Automatic Add:** SofType has a feature, which allows you to automatically save words that are not included in the word list. Open the Word Bar Settings from the **View** menu and select **Automatically add new words**... This will open the Auto Add
Settings dialog box [See figure 25]. In this dialog box select Auto add words, then select the desired criteria for adding new words.

Selecting the Show “Edit Auto Words” dialog at SofType exit check box will open a dialog box before SofType closes, from which you may edit/delete any words automatically entered. You can open the Edit Auto Words… dialog box at any time by selecting it from SofType’s File menu.

Selecting Ignore mixed case will prevent words with mixed case, such as SofType, to be automatically added. You may still add these words to the word list using the other methods.

Ignore all CAPS will prevent these words from being automatically added to the word list.

You may also select how many times the word must be typed and the least number of characters it must have before it is automatically added to the word list by entering the desired number in the Type word and Words are fields. After you have made your selections, click OK.

**Import Words:** This feature is used to quickly and easily add new words to an existing word list dictionary or create a new word list dictionary. Import Words expects carriage return/linefeed delimited text files as input. The import function is not intelligent; it considers a word as a string of characters of 3 or more letters and will reject all punctuation marks. Before importing words, the desired language must be selected from Windows settings and Dynamic Words must be selected from SofType’s Word Bar settings. This will make it possible for SofType to automatically load the language dictionary that corresponds to the language in use.

To use this feature select Import Words… from the File menu, then select the desired text file and click Open. This will open the Import Words dialog box. [See figure 26a] Under Import Mode in the Import Words dialog box select "Add to existing word list" or "Create new word list". From the “Include Words That Have:” area, select the desired criterion as follows:
**SofType Chapter 3**

- **All CAPITALS:** Words consisting of all capital letters will be imported.

- **Initial Capitals:** Words beginning with a capital letter will be imported.

*Note: Words with MiXed case are also imported when this option is selected.*

- **Apostrophe:** Words containing an apostrophe are imported.

- **Hyphenated-words:** Words joined by a hyphen are imported.

Selecting the **Backup current word file** option creates a backup of the current word file before the import begins. SofType will name the backup file as follows: "SofType Words.xxxbackup" where xxx is a 3 digit number.

*Note: Backup word files are never deleted by SofType.*

Click the **Import** button after the desired selections have been made. The Import Words dialog box will then display the import file statistics. [See figure 26b] The user may now select **Done** to close the Import Words dialog box or **Edit Words** to edit the new word list. The word list may be edited at a later time if preferred.

---

**Load Dictionary**

To manually load a word list dictionary select **Load Dictionary…** from the **File menu** then select the desired dictionary and click **Open**.

**Edit Words Menu**

In the Edit Words dialog box words can be added, removed and edited within a word list. The **COMMON WORD** list can be re-ordered as well. Begin by selecting **File**, then **Edit Words**. This will open the Edit Words dialog box. [See figure 27]

Use the Move word buttons to re-order the **COMMON** words as desired. Select the word to be moved then select the **Up** or **Down** button to move it within the word list. The word list is grouped alphabetically with the **COMMON word group** listed in the beginning.

Selecting the **Next** and **Previous** buttons will display the next/previous letter group. To add a word, begin by selecting the letter group that the word is to be added to. Select the **Insert…** button; enter the word being added then select **OK**. It is important to note that the word will be added to the word list that is currently displayed. For example, if the
word list for the letter group "A" is displayed and you insert the word "zebra", the word "zebra" will be inserted into the "A" letter group.

![Edit Words dialog box](image)

**Figure 27: Edit Words dialog box.**

**Edit and Delete Words in a Word List**

To edit a word, select it from the word list and click the **Edit** button, make the desired correction and click **OK**. To delete a word, select it from the word list, click **Add** to move it into the **To Delete:** list, and then click the **Delete Words** button. Several words may be moved to the delete list and deleted all at one time.

**Word Statistics**

When the **Statistics...** button is selected from within the Edit Words dialog box, the Word Statistics dialog box opens. This dialog box contains the dictionary word count information. The number of words within each word list group is displayed as well as the total number of words in all word list groups.

Save Prediction Statistics, located in the Word Bar Settings dialog box, is used to determine when and how often you want to save SofType's dictionary file. The settings chosen here are only effective when Completion Mode is set to **Prediction**. Save Prediction Statistics settings are used to keep Word Prediction statistics up to date in the dictionary file. Resetting the word usage statistics can be done by selecting **Reset Frequency** from the **File** menu; this will also alphabetize all the words in the word prediction dictionary.

When the **On Exit Only** check box is selected, the dictionary file will only be saved when you quit SofType. The **Every x Selections** field determines the number of selections that must be made from the Word Bar (1-20) before the dictionary file will be saved.
Using Abbreviation Expansion

Abbreviation Expansion is a feature, which allows the user to define a specific string of characters that SofType would then expand into longer, more complex character strings. As a result, long character sequences can be entered with a minimum of three keystrokes, two keystrokes followed by a space. For example, "ST_" could be defined to expand to "SofType On-screen Keyboard". An abbreviation can be 2 to 5 characters and is case sensitive. Using the example above "ST_" would be different than "st_".

To use this feature you must first enable it by selecting Use Abbreviations from SofType's Keyboard menu. Type the defined abbreviation then the Space or Enter key; using the example above, you would type "ST " to command SofType to first delete "ST", then type, "SofType On-screen Keyboard."

Defining/Editing Abbreviations

To define an abbreviation, select Edit Abbreviations from the Keyboard menu. This will open the Add/Edit Abbreviations dialog box. [See figure 28] Enter the desired abbreviation into the Abbreviation: edit field then enter the expanded text into the Expands to: edit field. Abbreviations must be alpha characters only. Expanded text may be up to 128 characters and may include macro commands. Select the Add To List button to add the new abbreviation to the user-defined list of abbreviations. You may continue to add new abbreviations consecutively to the list. Your abbreviations will be displayed in alphabetical order.

Selecting an abbreviation from the list displays it in the Abbreviation: and Expands to: fields where you may edit the abbreviation or text, or you may delete it by selecting the Delete From List button. If you wish to clear the editing fields, select the Unselect From List button. Selecting this button will only clear the editing fields; the list will not be affected. After you have made the desired additions/changes, select Done. Clicking the Cancel button at anytime will close the dialog box without implementing any changes.
Using Macros

Before defining a macro, you should first understand what it is and how it works. SofType's Macro feature allows you to type phrases and other commonly used strings of text and commands, with only 2 keystrokes. For example, you could define a macro to enter your name and address. This would more quickly allow you to address an envelope or create a letterhead.

To use this feature you must first enable it by selecting Use Macros from SofType's Keyboard menu. Select the Macro Button on the keyboard, [See figure 29] and then select the character key associated with the defined macro. (Note: some keyboard layouts do not contain the Macro Button. Refer to the keyboard layout diagram on page 10.) SofType will then enter the text and commands associated with that macro into your application. For example, the "o" key could be assigned to enter the following text:

Origin Instruments Corp.
854 Greenview Dr
Grand Prairie, TX 75050

Macro Commands

Macro commands are imbedded commands to the macro engine to perform special tasks. These commands consist of a backslash (\) and up to two characters.

\t .................- types a Tab key.
\n ...............- types an Enter key.
\p .................- pauses typing for .5 second.
\ds ................- types the short form of the current date, (02/20/00)
\dl ...............- types the long form of the current date, (Friday, February 20, 2000)
\xs ...............- types the current time without seconds, (01:30 PM)
\xm- .............- types the current time without minutes and seconds, (01 PM)
\xl ...............- types the current time, (01:30:45 PM)
\xt ...............- types the current time in 24 hour format, (13:30:45)
\ \ ................- types a backslash.

Defining/Editing Macros

To define or edit a macro select Edit Macros from SofType's Keyboard menu. This item will not be available unless Use Macros is selected. Select the key that you want to assign the macro to (if you are editing a macro, select the previously assigned key); this will open the Edit Macro dialog box. [See figure 30] Type the desired string of text and macro commands. You may enter up to 128 characters. The dialog box will display the number of characters in your text as you type. After you have entered the desired text, click OK. You must unselect Edit Macros in order for SofType to execute the defined macro the next time you select it.
Macros may be defined for all keys except the following: Ctrl, Alt, Shift, Caps, Lock, Num Lock, Scroll Lock or the macro key itself.

Note: When Edit Macros is selected, SofType must be the active application in order to edit/add macros. If SofType is not the active application, anything you type will appear in the active application.

**Macro Tips**
Marco Tips is a feature that will display a macro description in a tip window when the pointer moves across a defined macro key. This tip window is visible when Macro Tips is selected from the Keyboard menu and the Macro Key is selected or a defined macro key is selected to edit.

**Example Macros**
The **bolded** examples below will enter the following text by first selecting the Macro Key and then the assigned character key.

**username\tpassword\n**
To complete a User Name/Password dialog box or web page.

**Joe Smith\n720 Highland\nCalm, MS 00000-0000\n**
Joe Smith
720 Highland
Calm, MS 00000-0000

**Hello everyone! My name is Sally. It's \dl, \xs here.**
Hello everyone! My name is Sally. It's Friday, February 20, 1998, 01:30 PM here.

**Joe Smith\n720 Highland\nCalm, MS 00000-0000\n(555)-555-1234\n**
To complete a typical name/address dialog box.
Index

A
Abbreviation Expansion ......................... 35
AutoClick
dwell time ........................................ 27
on/off ............................................. 25
settings ........................................... 25
sound ............................................. 27

B
Blackhand Menu .................................. 11

C
Clicking Functions ..... 26. See AutoClick
repeat click ...................................... 27

D
Dragger
dock .................................................. 10, 23
float .................................................. 24
lock buttons ..................................... 26
on/off ............................................. 23
orientation ....................................... 24
settings ........................................... 27
buttons ........................................... 25
toolbar ........................................... 23
Dynamic Words .................................. 30

F
File Menu ........................................... 7

H
Help Menu ......................................... 10

I
import words ..................................... 31

J
Jitter Box .......................................... 26

K
Keyboard
appearance ...................................... 7
hide/show ....................................... 18
Layouts .......................................... 12
editing ........................................... 16
placement ...................................... 18
size ............................................... 18
Keyboard Menu ................................ 9
Keys
color ............................................. 20
font .............................................. 20
size .............................................. 19

L
load dictionary .................................. 32

M
macro ............................................... 36
commands ....................................... 36
Menu Bar ........................................ 7
Hide .............................................. 19
Mouse Menu .................................... 9

P
pointer
size ............................................... 9

R
Reboot ............................................ 12
Run Menu ........................................ 8

S
Show Case ....................................... 29
startup options
command line options ....................... 8
Status Bar ...................................... 10
Hide ............................................. 19

text entry ...................................... 29
capitalize ..................................... 29
Title Bar ........................................ 7
Hide ............................................. 19

V
View Menu ...................................... 9, 18

W
Word Bar .......................................... 10, 11
Hide ................................................... 19  statistics .................................................. 33
Word List                           word list dictionary ............... 31
  edit ............................................. 30, 32  Word Prediction ....................... 29